1

NAS Drive / Mapped Drives

 

Need some help with my external hard drive set up...

I've recently set up a new router, an Asus RT-AC87U with a 5TB Seagate External USB 3.0 drive attached to it as the NAS drive.

I can add the network folder locations on the NAS to the PlayOn Library and/or as the PlayLater download location but when using PlayOn on devices or in the PC app the folders are not listed in My Media and/or PlayLater. And if I map a network drive location on the PC running PlayOn so that it'll have a drive letter, the mapped drive letter location on the NAS won't even appear when trying to add as a Library location....

What is preventing the NAS drive and folders from being available? I'd like to designate this NAS drive as my default download location for PlayLater and use for my video library. The Roku Media Player sees the NAS just fine, as does other devices including my PC. 

Is there a "how to" on setting up a NAS drive or something simple that I'm overlooking? Any help is welcome, thanks!

7 comments

  • 0
    Avatar
    Ellery July

    Did you ever get a response to your playon saved to a nas?

  • 0
    Avatar
    Brian

    I am experiencing the exact same thing. I have a mapped drive to a Western Digital 3TB network drive but PlayOn does not list the drive for me to select it as part of my Media Library.

    What do I need to do to get this to work?

     

     

  • 0
    Avatar
    Adam

    Settings

    Change Video recording location to network drive

    any future recordings show up under playon recordings

     

     

    for already owned media go to

     

    settings

    media library

    enable

    add

    find directory 

    do not insert username password

     

    my movies were added as a mapped drive, my shows as a network location.  both work, but both show like they are network locations

     

  • 1
    Avatar
    Ched Capps

    Has anyone been able to address this issue?  I have tried the steps suggested by Adam, however PlayOn desktop app does not see any mapped network drives. The PC has them mapped and has full access to them. Other Media Apps (Plex) have access to them from the same machine. But PlayOn does not see them.

  • 0
    Avatar
    agenno

    I had to turn off my VPN application...still trying to figure out how to get Private Tunnel OVPN activated on m ASUS RT-AC66U router.  I've tried entering the username/password I setup in SMB account on the router, I've tried leaving it blank...recordings always fail.

     

    I hope Playon actually pays attention to this thread so we can get this issue resolved.

  • 0
    Avatar
    Luis Espinoza

    It worked for me, the trick is not use the already mapped drive, instead when selecting the destination folder you have click on "Network" and then go to the "Computers" section to look for the PC o NAS with the shared drive, select it , enter the user and password ( if required ) and select the folder you want to add.

  • 0
    Avatar
    Nick Puzo

    Hey everyone... or anyone that still checks the forum lol. This issue pissed me off to the point of abandoning the NAS set up, but I didn't forget about it and after moving recently I decided to fool with it again. I ran into a few things that may contribute like Windows 10 now disabling the SMB 1.0/CIFS File Sharing Support in features along with a few others due to security risks. This was an issue for my Windows 10 machine no longer being able to see my NAS as a network/mapped drive through my Asus RT-AC87U router.

    With this fix I can now also access local shared folders on my PC from AiCloud I was unable to see before. Once I figured all that out I dove back into my original issue with PlayOn not being able to see the NAS. Here's a link for enabling/disabling SMB http://www.thewindowsclub.com/disable-smb1-windows that may prove helpful. My NAS Folders now appear under Network.


    Now there is a little trick to PlayOn that should make it visible there but comes with it's own set of issues... User Run Mode, get to that in a sec. But 1st because of how PlayOn runs as a system service, you would need to ensure that your NAS provides open access to either the local SYSTEM account or allow 'anonymous' access to the shared folder. If you're using an ASUS router like I am and you've conquered mapping to your NAS drive, but still can't see your folders/files in PlayOn... Go to USB Application, then click on Media Services and Servers.

    Go to the Network Place (Samba) Share / Cloud Disk tab, turn Allow guest login to ON. 

    By enabling [ Allow guest login ], any user in the local network can access your network place(Samba) without authentication! Which unless you're running PlayOn and your networks at a business with multiple users (or your friends are all nosy hackers) it shouldn't be a big issue on a local home network. Also make sure your WORKGROUP matches your PC.

    Add your Media Folder(s) to PlayOn through the now available Network location and leave the Network Share fields blank, press OK then Apply and give it a minute or 2 to scan the folders if you have a lot of content.

    This, along with enabling the the SMB File sharing I mentioned previously now has all my NAS folders & files visible everywhere I run a PlayOn Client. Though enabling SMB comes with security risks... supposedly. 

    NOW, If all that is impossible for you or it still didn't do the trick, you can force PlayOn to run under your user account using the steps below.

    1) Stop the PlayOn Server, if it's running, by clicking the Stop button inside PlayOn Settings
    2) Press and hold the CTRL key on your keyboard while clicking the Start button in PlayOn Settings
    3) The Status box should turn blue and show as "User Run" It will eventually turn green again and display "Running"

    This mode worked for me but is very laggy, and the local PlayOn client on my PC doesn't like it, freezes up and never connects. But other remote devices do just fine and see the NAS. Updates also won't perform automatically in this mode. And the only way out of this mode is to kill the PlayOn server through task manager then relaunch the server.

    Hope this helps someone!

Please sign in to leave a comment.